Bug report #4182

Symbol levels don't work with Rule Based Renderer

Added by Anita Graser about 9 years ago. Updated about 9 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Symbology
Affected QGIS version: Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:14158

Description

When a rule based renderer is used, it is not possible to activate symbol layers.

History

#1 Updated by Richard Duivenvoorde about 9 years ago

Hi Anita, I'm running master here, and using Rulebased Renderer in a python plugin.

But I can add rules, and for every rule I can open the style and then add other symbol layers...

(trying with polygons here...)

What do you mean with 'not possible to activate'?

#2 Updated by Anita Graser about 9 years ago

Sorry, I meant symbol levels not layers.

#3 Updated by Anita Graser about 9 years ago

  • Subject changed from Symbol layers don't work with Rule Based Renderer to Symbol levels don't work with Rule Based Renderer

#4 Updated by Martin Dobias about 9 years ago

There are related tickets #3222 #3039 #2832 with quite discussions. There were some more discussions on the dev mailing list.

I am somehow reluctant to enable usage of symbol levels for rule-based renderer because this would limit us to one rule per feature. For qgis 1.7.0 it was decided to apply a patch that allows symbol levels for rule-based renderer. But for longer term (qgis 2.0) I would like to see a different approach of defining rules similar to SLD.

#5 Updated by Anita Graser about 9 years ago

  • Resolution set to duplicate

If it's a conscious decision to not allow symbol levels in rule based renderer, I think the button should be greyed out. Otherwise users start to wonder why it simply does not work.

I'll close this as duplicate of #3039

#6 Updated by Anita Graser about 9 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF