Bug report #4168

custom CRS: stripped chars in projection_acronym

Added by William Kyngesburye about 8 years ago. Updated about 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Projection Support
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14145

Description

When defining a custom projection, numbers are stripped from the +proj projection name for the projection_acronym. Then the projection doesn't show up as a CRS choice elsewhere in QGIS (it is only in the Custom CRS definition window). ie: +proj=eck4, projection_acronym=eck. If I edit the sqlite table and correct the projection_acronym, the custom projection shows up as a custom CRS choice.

History

#1 Updated by Tim Sutton almost 8 years ago

  • Target version changed from Version 1.7.1 to Version 1.7.2

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.2 to Version 1.7.3

#3 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.3 to Version 1.7.4

#4 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

#5 Updated by Magnus Homann about 7 years ago

  • Status changed from Open to Closed

I can't reproduce this in master.

Also available in: Atom PDF