Bug report #4115

copy an object from a layer and insert it into a sqlite layer is not possible

Added by Gerhard Spieles over 8 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:14097

Description

copying an object from a layer to an sqlite layer terminates while saving with a popup window "fault: Object not insert".
jpg is attached.

sqlite_copy_insert_object_fault.jpg (196 KB) Gerhard Spieles, 2011-07-25 12:14 PM

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Target version set to Version 1.7.4

#2 Updated by Paolo Cavallini almost 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#3 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#5 Updated by Médéric RIBREUX over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Hello, bug triage...

I can't reproduce it in QGIS 2.13 master. I can paste any object from a layer to a Spatialite one even if the field structure is different.

I am closing this bug.

Also available in: Atom PDF