Bug report #4104

error ' attribute value change(s) not applied' when editing csv files

Added by Richard Duivenvoorde about 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System:ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:14086

Description

I'm working on a plugin which should make it possible to load a single dbf (or csv file) and fill an x- and y-column by clicking in a map. And after that: save the txt file as a point-shape file using those xy columns as geometry xy's.

I noticed that when opening a dbf file (just via open vector layer), I can edit values and add records in the attribute table view and successfully save the dbf.

But when opening a csv file, I can add a record (most of the time) and save it (though I see ERROR messages sometimes in cells).

But I can NOT change value's of table-cells. Every time I try to do that I get an error:
Errors: ERROR: 1 attribute value change(s) not applied.

I'll attach a minimum tab-separated csv file to this message to do some testing.
I work on a self compiled qgis b72b7b1 on ubuntu natty.

kuus.csv Magnifier (67 Bytes) Richard Duivenvoorde, 2011-07-20 02:59 AM

History

#1 Updated by Richard Duivenvoorde about 9 years ago

#2 Updated by Paolo Cavallini almost 9 years ago

  • Category set to Data Provider

#3 Updated by Giovanni Manghi almost 9 years ago

  • Target version set to Version 1.7.4

#4 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0

#5 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#7 Updated by Médéric RIBREUX almost 5 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

this is still true in QGIS 2.13. It seems to be an OGR problem as the CSV driver page states:
Deleting or replacing existing features is not supported.

I think this is an OGR bug and not a QGIS one. Could we close this one (after you have made a bug report on GDAL side) ?

#8 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to up/downstream

Also available in: Atom PDF