Bug report #4097

Referenced layers (embedded layers) do not maintain visibility state

Added by Andreas Neumann almost 9 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Marco Hugentobler
Category:Project Loading/Saving
Affected QGIS version:master Regression?:No
Operating System:all Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14079

Description

When embedding/referencing groups or layers from other projects, their visibility state is not maintained when saving and reloading the project.

In some cases it may be desirable to reference a group but set it to invisible. Currently, the root of the referenced group shows the correct visibility state, but all childs are always visible after a reload.

Associated revisions

Revision b49da36c
Added by Jürgen Fischer over 5 years ago

  • Save and restore visiblity state of embedded group layers (fixes #4097)
  • Adds support for lists in custom properties

History

#1 Updated by Andreas Neumann almost 9 years ago

  • Assignee set to Marco Hugentobler

#2 Updated by Marco Hugentobler almost 9 years ago

d02c4bef94be82dca4a4 considers visibility for embedded groups and their sublayers.
For single embedded layers, the implementation needs more thinking because the visibility is not stored in the layer element itself.

#3 Updated by Giovanni Manghi over 8 years ago

  • Target version set to Version 1.7.4

#4 Updated by Paolo Cavallini about 8 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0

#5 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#7 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF