Bug report #4041

segfault when trying to open layer properties

Added by Richard Duivenvoorde about 9 years ago. Updated about 9 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:linux Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:14027

Description

trying to test a join between a simple shape file and a sqlite database I get a segfault with current master/head 4d75a7d

opening both shape and sqlite are ok

making the join is ok

but after making the joint trying to open the shape file properties again segfaults

thinking it had something to do with sqlite I also tried a dbf file but with same result

attached are the shapefile (called shape) with three points, and a kaas.db (sqlite) and kaas.dbf as non spatial tables to be joined

jointest.zip (2 KB) Richard Duivenvoorde, 2011-07-01 07:43 AM

History

#1 Updated by Nathan Woodrow about 9 years ago

Seems to be related to the same ticket I opened. #4045

#2 Updated by Nathan Woodrow about 9 years ago

Can you try again and see if there is still a issue. It should be fixed in b2c7bae948

#3 Updated by Richard Duivenvoorde about 9 years ago

  • Resolution set to fixed

yep, now working thanks to rb2c7bae948 :-)

setting resolution to fixed

#4 Updated by Richard Duivenvoorde about 9 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF