Bug report #4039

wms layerorder dialog missing icons and wrong tooltips

Added by Richard Duivenvoorde about 9 years ago. Updated over 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version: Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:14025

Description

In the wms-layer dialog, in the 'layer-order'-tab, both icons for changing the layer order are missing.

And they show a tooltip 'Save connections to file'

See screenshot

Buttons for bringing layers up and down are working ok, though!

layerorderbuttons.png (31.6 KB) Richard Duivenvoorde, 2011-07-01 02:06 AM

wmslayermove.patch Magnifier (1.14 KB) Richard Duivenvoorde, 2011-07-01 08:06 AM

Associated revisions

Revision 1a140343
Added by Richard Duivenvoorde about 9 years ago

fix #4039

History

#1 Updated by Richard Duivenvoorde about 9 years ago

don't know if we had an icon there. But I opened the ui file in designer, and added 'Up' and 'Down' as caption of the buttons, and changed tooltips.

See attached patch

If there are supposed to be icons on the buttons, feel free to ignore this patch :-)

#2 Updated by Richard Duivenvoorde over 8 years ago

  • Pull Request or Patch supplied set to No
  • Resolution set to fixed
  • Status changed from Open to Closed

Close it: A patch like this is applied, button icons not preferred, because this needs QgisApp code which is not available in providers.

Also available in: Atom PDF