Bug report #3963

Crash when applying a graduated vector style

Added by Jean-Roc Morreale over 8 years ago. Updated over 7 years ago.

Status:Closed
Priority:High
Assignee:cfarmer -
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:13965

Description

When I apply a graduated classification a shp layer, QGIS dies. It happens on Windows (qgis-dev from osgeo4w) and linux (master branch from sunday), it also happens if the layer (same data) is in spatialite.

I'm joining the full gdb backtrace.

backtrace_qgis.log Magnifier - gdb's log (58.5 KB) Jean-Roc Morreale, 2011-06-07 01:47 PM

History

#1 Updated by Martin Dobias about 8 years ago

The backtrace suggest that it crashes when calculating breaks for Jenks classification. A sample of your data causing the problem would be very helpful in order to track down the error.

#2 Updated by Paolo Cavallini about 8 years ago

  • Pull Request or Patch supplied set to No

Please jrm send us feedback - if we cannot replicate it, we cannot fix it.

#3 Updated by mlennert - about 8 years ago

I can replicate this bug in the following manner:

Moritz

#4 Updated by Giovanni Manghi about 8 years ago

  • Assignee set to Martin Dobias
  • Target version changed from Version 2.0.0 to Version 1.7.1

Confirmed under Ubuntu 11.04 64 bit and qgis trunk.

This is the error message

Fatal: ASSERT failure in QList<T>::operator[]: "index out of range", file /usr/include/qt4/QtCore/qlist.h, line 464
Aborted

mlennert - wrote:

I can replicate this bug in the following manner:

Moritz

#5 Updated by Martin Dobias almost 8 years ago

  • Assignee changed from Martin Dobias to cfarmer -

I am unable to tell what is going on in the algorithm for natural breaks, the references lead only to implementations, not to theory and formulas.

Maybe Carson will have a better idea what's going wrong since he has ported it to QGIS.

#6 Updated by Tim Sutton almost 8 years ago

  • Target version changed from Version 1.7.1 to Version 1.7.2

#7 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.2 to Version 1.7.3

#8 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.3 to Version 1.7.4

#9 Updated by Giovanni Manghi over 7 years ago

  • Crashes QGIS or corrupts data set to Yes
  • Priority changed from Normal to 6
  • Operating System deleted (windows, linux)
  • OS version deleted (trunk)
  • Affected QGIS version set to master

still true on qgis-master under Ubuntu Linux and Windows

Fatal: ASSERT failure in QList<T>::operator[]: "index out of range", file /usr/include/qt4/QtCore/qlist.h, line 464
Aborted

#10 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF