Bug report #3802

QGIS crashes using some options of new labelling tool

Added by aperi2007 - over 8 years ago. Updated almost 7 years ago.

Status:Closed
Priority:High
Assignee:Martin Dobias
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:Yes Copied to github as #:13860

Description

QGIS (version 15861M) crash always with this sequence of commands.
On windows 7.

1. Load shapefile "linee.shp"
2. Load shapefile "suolo.shp"

3. using label-plugin set the "suolo.shp" to show the label on field 'id'
and choose option advanced: "label every part of multipart features" and
chose also Placement->free option.

click on ok and close plugin.

4. using the label-plugin set the "linee.shp" to show the label on field 'id'
and choose advanced: "label every part of multipart features"

click on ok and close plugin

after the click the qgis crash...

I add the two shapefile as samples, but this happened with every couple of shapefiles.

Andrea.

shapefile-samples.zip - sample shapefile for crash (3.01 KB) aperi2007 -, 2011-05-05 03:34 PM

History

#1 Updated by Giovanni Manghi almost 8 years ago

  • Pull Request or Patch supplied set to No
  • Subject changed from qgis crash using some option of labels-plugin to (Windows) QGIS crashes using some options of new labelling tool
  • Assignee changed from Marco Hugentobler to Martin Dobias
  • Target version deleted (Version 1.7.0)
  • Must fix deleted (No)

I tested qgis-trunk on both Ubuntu Linux and Windows 7 and the issue it seems to be a Windows only one.

It is not necessary to add the line layer and label it to replicate the issue, QGIS crashes also with just the polygon layer (with the labels and the settings as described) after doing a simple pan or zoom operation.

#2 Updated by Paolo Cavallini over 7 years ago

  • Category changed from Symbology to Labelling

Still true?

#3 Updated by Giovanni Manghi over 7 years ago

  • Target version set to Version 1.7.4

#4 Updated by Giovanni Manghi over 7 years ago

  • Priority changed from Low to 6
  • Status info deleted (0)
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to Yes

It is not necessary to add the line layer and label it to replicate the issue, QGIS crashes also with just the polygon layer (with the labels and the settings as described) after doing a simple pan or zoom operation.

still true on qgis-master or 1.7.3 osgeo4w

#5 Updated by Giovanni Manghi over 7 years ago

Does not crash under qgis-master/Ubuntu.

#6 Updated by Giovanni Manghi over 7 years ago

  • Subject changed from (Windows) QGIS crashes using some options of new labelling tool to [Windows] QGIS crashes using some options of new labelling tool
  • OS version deleted (7)

#7 Updated by Giovanni Manghi over 7 years ago

still true on qgis-master or 1.7.3 osgeo4w

still true on both and just on Windows

#8 Updated by Giovanni Manghi over 7 years ago

  • Priority changed from 6 to High

#9 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#10 Updated by aperi2007 - over 7 years ago

I tested on qgis-dev E5D97F5.
The crash seem disappeared.
Is confirmed ?

( I add another information.
The test was do on windows XP 32bit.)

#11 Updated by Giovanni Manghi over 7 years ago

aperi2007 - wrote:

I tested on qgis-dev E5D97F5.
The crash seem disappeared.
Is confirmed ?

still crashes here.

#12 Updated by aperi2007 - over 7 years ago

I tested it on windows 7 64 bit.
It crash !

Instead seem that the crash don't happen on windows xp 32bit.
It is a specific crash for windows 7 (I don't know if it crash on 32bit version).

#13 Updated by Giovanni Manghi over 7 years ago

aperi2007 - wrote:

(I don't know if it crash on 32bit version).

it does

#14 Updated by Jürgen Fischer over 7 years ago

  • Subject changed from [Windows] QGIS crashes using some options of new labelling tool to QGIS crashes using some options of new labelling tool

#15 Updated by Giovanni Manghi over 7 years ago

Giovanni Manghi wrote:

aperi2007 - wrote:

(I don't know if it crash on 32bit version).

it does

still confirmed with the lastet master

#16 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#17 Updated by Giovanni Manghi almost 7 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

With the latest changes in labelling code this seems fixed.

Also available in: Atom PDF