Bug report #3765

on trunk/windows ECW files take a long time to open (qgis hangs)

Added by Giovanni Manghi over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13824

Description

I hate this, because I cannot care less about the ECW format, but people using qgis-dev/osgeo4w started complain about this.

I does not happens on 1.6 and I'm pretty sure it wasn't happening also on trunk until a couple of weeks ago (but I cannot be 100% sure).

Small ECW files does not seems to create problems, but for example a 20MB one is enough to replicate it.

History

#1 Updated by Giovanni Manghi over 9 years ago

it affects also qgis trunk on linux, compiled against gdal 1.7 and with the very old erdas sdk for linux. So it should be a qgis issue, maybe related to the latest changes in the raster provider.

http://ubuntuone.com/p/oWs/

#2 Updated by Giovanni Manghi over 9 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

somehow this has gone on both Linux and Windows.

#3 Updated by Nathan Woodrow over 9 years ago

  • Resolution deleted (worksforme)
  • Status changed from Closed to Feedback

This is still a issue on my Windows machine. The problem seems to have been introduced with the new raster provider as it was working file until then. Running latest windows qgis build.

#4 Updated by Giovanni Manghi over 9 years ago

when I opened the ticket I had the issue on both linux and windows, now I cannot see it anymore on both OS. I also tested > 100mb ECW and it opens fast as expected.

I suspect that this can be related to local installation situations. I had a mix of gdal libraries in my linux pc due to different repositories installed and I was seeing many problems with rasters. After a cleaning and reinstalling from source it works all ok.

I reinstalled completely also QGIS from osgeo4w after having removed it not using the same installer: i removed the shortcuts and the osgeo4w installation directory and the cleaned everyhting with ccleaner and other tools for the Windows registry. Upon reinstallation I'm not having anymore problems.

Could you give it a try?

I have no problems with for example this 90mb ecw image

http://www.pfc.forestry.ca/eosd/resources/mosaic/2000/Canada_Mosaic_2000_250m_ecw.zip

#5 Updated by Nathan Woodrow over 9 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

I stand corrected :) I had the Raster Value plugin installed which queried the raster every time the mouse moved, you can image the effect using a 5.5GB ecw this would have. Disabled the plugin and everything is fine again.

#6 Updated by Giovanni Manghi over 9 years ago

unfortunately this means we have a problem with the value tool plugin, a tool that is so useful and fundamental (when doing raster analysis for example) that in my point of view should be moved into core, as the author more or less said that has no time to maintain it.

Also available in: Atom PDF