Bug report #3749

labels out of view for long straight lines

Added by Mayeul Kauffmann over 9 years ago. Updated about 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13808

Description

When a line feature as only one segment (2 points), the label is put in the middle, even if the middle is out of the map canvas, hence not visible (see attached screenshot).

bug_labels_out_of_view_for_long_straight_lines.png (70.9 KB) Mayeul Kauffmann, 2011-04-16 09:47 AM

History

#1 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

#3 Updated by Paolo Cavallini over 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Regis Haubourg about 8 years ago

not reproduced on master here. Tested also multineString.

#5 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Médéric RIBREUX about 5 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Closed
  • % Done changed from 0 to 100
  • Resolution set to fixed/implemented

Hello, bug triage...

I can't reproduce it on QGIS 2.13 master. The new labelling engines have fixed this bug because the labels are always displayed on the lines.

I am closing this bug.

Also available in: Atom PDF