Feature request #3748

Centralized way of sharing styles

Added by Saber Razmjooei about 6 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Symbology
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No

Description

It will be great to have a central repository of styles and SVGs. There could be a python-installer-like interface to download symbols and styles directly from the repository.

History

#1 Updated by Paolo Cavallini about 6 years ago

I think this implies several components (so the ticket could be split):

  • add .qgis/symbols to the standard path where to look for symbols
  • add a Symbol installer, similar to Plugin installer, to download sets of symbols to the above dir
  • add one or more central repo, parallel to the plugin repo, where users can upload styles.

Additionally, care should we taken because having many symbols will make opening the Property window very slow; a solution should be found to this issue.

Also custom XML styles for symbology-ng can be added to this, but this would require to split the monolithic symbology-ng-style.xml into chunks that can be up- and downloaded.

Overall, not a great effort, and will make life easier for many users.

#2 Updated by Saber Razmjooei about 6 years ago

I think your suggestions are pretty much what I meant, But I will leave the ticket open to see what others think.
If no comments, close it and open new ones.

#3 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#4 Updated by Giovanni Manghi about 5 years ago

  • Target version changed from Version 1.7.4 to Version 2.0.0

#5 Updated by Pirmin Kalberer over 4 years ago

  • Target version changed from Version 2.0.0 to Future Release - Nice to have

#6 Updated by Paolo Cavallini over 4 years ago

  • Assignee changed from Giuseppe Sucameli to anonymous -

#7 Updated by Paolo Cavallini about 3 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate
  • Pull Request or Patch supplied set to No

Duplicate of #1063

#8 Updated by Jürgen Fischer almost 3 years ago

  • Assignee deleted (anonymous -)

Also available in: Atom PDF