Feature request #3734

WMS reprojection if current CRS is supported by server

Added by Redmine Admin about 6 years ago. Updated over 1 year ago.

Status:ClosedStart date:04/17/2012
Priority:LowDue date:
Assignee:Magnus Homann% Done:

100%

Category:WMS Client
Target version:Future Release - Nice to have
Platform:All Resolution:fixed/implemented
Platform version: Pull Request or Patch supplied:No
Status info:0 Tag:

Description

There seems some resampling going on when requesting a CRS
which the server supports (with enabled OTF):

http://www.catais.org/otf_off.png
http://www.catais.org/otf_on.png

e.g. QGIS set to EPSG:4326 and requesting an EPSG:4326 image from a
server that supports EPSG:4326.

Originally reported: http://lists.osgeo.org/pipermail/qgis-developer/2011-March/013287.html

History

#1 Updated by Redmine Admin about 6 years ago

WMS driver does not automatically switches to
projection requested by QGIS even if it is supported by WMS server.
You have to manually select the right projection when layer is added.

Preferably, the WMS driver should not only to switch to the right
projection, but also automatically
select the most similar projection offered by server if no one exactly
matches. Anybody is aware of an algorithm or ready for use method
doing that?

#2 Updated by Jürgen Fischer about 6 years ago

might #3740 be a duplicate of this?

#3 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#4 Updated by Borys Jurgiel over 5 years ago

  • Causes crash or corruption set to No
  • Pull Request or Patch supplied set to No
  • Affected version set to master

I believe choosing the strictly matching projection (if any) is the most urgent (and the simplest) fix. I thought it was already implemented, but maybe I'm wrong.

#5 Updated by Paolo Cavallini about 5 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#6 Updated by Jürgen Fischer about 5 years ago

  • Tracker changed from Bug report to Feature request
  • Start date set to 04/17/2012

#7 Updated by Paolo Cavallini over 4 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#8 Updated by Paolo Cavallini over 4 years ago

  • Assignee changed from Redmine Admin to Magnus Homann

#9 Updated by Pirmin Kalberer over 4 years ago

  • Target version changed from Version 2.0.0 to Future Release - Nice to have

#10 Updated by Médéric RIBREUX over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Hello, bug triage...

on QGIS 2.13 master (and probably in previous versions), the WMS client set the CRS to the common CRS between the project and the WMS server. If my project is in EPSG:2154 and the WMS server have the layer I want to display in this projection, QGIS WMS client will choose EPSG:2154 by default and there is no reprojection.

I am closing this bug.

Also available in: Atom PDF