Bug report #3719

qgis_mapserv.fcgi empty (ghost) layer in GetCapabilities

Added by Alessandro Pasotti over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:13778

Description

I don't know if I'm doing something wrong, but it seems like an empty layer is added to GetCapabilities.

See attached project and xml response.

Tested in trunk.

qgis-client.qgs (5.49 KB) Alessandro Pasotti, 2011-04-11 10:57 AM

GetCapabilities.xml Magnifier (102 KB) Alessandro Pasotti, 2011-04-11 10:58 AM

History

#1 Updated by Marco Hugentobler over 10 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

Do you mean the toplevel layer? If yes, this is intended. There must be exactly one toplevel layer (because of the WMS xml schema) and the project layer / group structure comes under it. The toplevel layer gets the name / title from the qgs project title.

#2 Updated by Alessandro Pasotti over 10 years ago

Thank for the quick answer,

Yes, I meant the top-level layer, I did not set the project title (which was not required, after all) and got the blank name and title.

I think this could be a common pitfall, and perhaps could be avoided with one of the following approachs:

  • set the project title as mandatory (IMHO not a good idea)
  • provide a default project title for the WMS server (project file name ?)
  • raise a WMS exception if the title is not set

BTW, can you point me to the docs of the WMS server? I would like to add a short note about that blank name issue but I couldn't find them.

#3 Updated by Marco Hugentobler over 10 years ago

The idea with a default title (filename without .qgs) sound great.

Untoftunately, there are no up-to-date docs. There is a small wiki page about QGIS server (http://www.qgis.org/wiki/QGIS_mapserver_tutorial), but it needs more content (something for the hackfest?). You could add the notes about the toplevel group under the section 'Troubleshooting'?

#4 Updated by Marco Hugentobler over 10 years ago

Filename as default title added in 8a31ca5d (SVN r15696)

Also available in: Atom PDF