Feature request #3717

allow loading vector legend from text file

Added by mlennert - over 6 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Symbology
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No

Description

It would be nice to be able to load a vector legend/style from a text file. This could include categorised, graduated or rules-based legends.

As an example, imagine receiving a vector file of land use classes with an information about the colors these classes should be displayed in. It would be nice to be able to just take this information, massage it into the necessary text file format and load it. Currently this is possible for raster palettes, but (apparently) not for vector legends.

Moritz

History

#1 Updated by Jürgen Fischer over 6 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

You can already save the layer symbology to .qml files.

#2 Updated by Jürgen Fischer over 6 years ago

Replying to [comment:1 jef]:

You can already save the layer symbology to .qml files.

that is, from the layer properties that is (Save As Default/Restore from Default/Load/Save Style...)

#3 Updated by mlennert - over 6 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (invalid)

Replying to [comment:1 jef]:

You can already save the layer symbology to .qml files.

I'm am conscious of that possibility, but it does not really respond to the idea developed above. It is not an easy taks to create a .qml file from scratch when you have a list of codes and colors as input. What I was aiming at was some sort of mecanism to allow me to tell QGIS "I would like all polygons filled with a color and a black border brush of width XYZ, and you can find all the codes and their corresponding colors in RGB in the following text file".

I think this is a note too rare use case (e.g. downloading shapefiles of land use classes with an accompanying file giving the class to color key).

Reopening the ticket as it is (IMHO) not invalid...

Moritz

Moritz

#4 Updated by Micha Silver about 6 years ago

  • Pull Request or Patch supplied set to No
  • Assignee deleted (nobody -)

+1 for this suggestion.
FAO Geonetwork and the Africover project both distribute Land Cover data with standardized coloring for each land cover class in an excel file with R-G-B columns. It would be great to be able to convert those columns somehow directly into a qml...
Thanks,
Micha

#5 Updated by Giovanni Manghi about 6 years ago

  • Operating System deleted (Debian)
  • Target version changed from Version 1.7.0 to Version 1.7.1

This seems to me a duplicate of #3129

If you consider so please close it.

#6 Updated by Tim Sutton almost 6 years ago

  • Target version changed from Version 1.7.1 to Version 1.7.2

#7 Updated by Giovanni Manghi almost 6 years ago

  • Target version changed from Version 1.7.2 to Version 1.7.3

#8 Updated by Giovanni Manghi almost 6 years ago

  • Target version changed from Version 1.7.3 to Version 1.7.4

#9 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 1.7.4 to Version 2.0.0

#10 Updated by Pirmin Kalberer almost 5 years ago

  • Target version changed from Version 2.0.0 to Future Release - Nice to have

#11 Updated by mlennert - almost 3 years ago

  • Resolution set to duplicate

duplicate of #859

#12 Updated by Giovanni Manghi almost 3 years ago

  • Status info deleted (0)
  • Status changed from Feedback to Closed

data defined symbology exists since long ago now.

Also available in: Atom PDF