Feature request #3701

eVis: can't create layer from MS Access query

Added by Alexander Bruy over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:C++ Plugins
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:13760

Description

eVis throws error when trying create layer from SQL query. To reproduce:

1. create connection to the database
2. create query "select * from species". Enter any layer name and don't change coordinate comboboxes
3. Get error "Layer is not valid The layer C:/Temp/qt_temp.JC4076?delimiter= &xField=Lon&yField=Lat is not a valid layer and can not be added to the map"

Tested with r15645 and r15659

I think this is because of latest changes in delimited text provider and here is patch to fix this issue.

dbase.7z - Test database (6.82 KB) Alexander Bruy, 2011-04-04 10:44 AM

evis_add_layer_fix.diff Magnifier - Proposed patch (1.33 KB) Alexander Bruy, 2011-04-04 10:45 AM

Associated revisions

Revision 48d7e85e
Added by Alexander Bruy over 10 years ago

synchronize eVis with latest changes in delimited text provider (fix #3701)

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision b8f83497
Added by Alexander Bruy over 10 years ago

synchronize eVis with latest changes in delimited text provider (fix #3701)

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Alexander Bruy over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Applied in b8f83497 (SVN r15677)

Also available in: Atom PDF