Bug report #3699

silent plugin loading failure

Added by Sandro Santilli about 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:C++ Plugins
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13758

Description

I've noticed that when a core plugin loading fails qgis doesn't say anything, unless you build it in Debug mode.

It's pretty frustrating. Should errors in plugin loading be printed in Release mode too ?

History

#1 Updated by Sandro Santilli about 9 years ago

Just to give some more context: the plugin which is failing to load for me is grass, whose .so fails to find a few dependent libs:

$ ldd /usr/local/lib/qgis/plugins/libgrassplugin.so | grep 'not found'
        libgrass_gis.so => not found
        libgrass_vect.so => not found
        libgrass_dbmibase.so => not found
        libgrass_dbmiclient.so => not found
        libgrass_gproj.so => not found
        libgrass_gis.so => not found
        libgrass_vect.so => not found
        libgrass_dbmibase.so => not found
        libgrass_dbmiclient.so => not found
        libgrass_gproj.so => not found

#2 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Paolo Cavallini almost 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#4 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Médéric RIBREUX over 4 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Closed
  • % Done changed from 0 to 100
  • Resolution set to fixed/implemented

Hello, bug triage...

in QGIS 2.13 master (and probably in previous versions), when a plugin can't be loaded, there is a log message displayed in the Log Messages Panel.
I've got problems with my GRASS installation and QGIS reports it:

Failed to load /home/medspx/apps/lib/qgis/plugins/libgrassplugin7.so (Reason: Cannot load library...

I am closing this bug.

Also available in: Atom PDF