Bug report #3684

Categorized renderer can't handle trailing spaces

Added by Anita Graser over 8 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13743

Description

Trailing spaces are ignored/truncated by the classification. Then, the renderer can't find the truncated values. Debug output is: ( symbolForValue ) attribute value not found: xxx

The features are not drawn.

(Tested with a postgis layer)

History

#1 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

#3 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Jürgen Fischer about 5 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#5 Updated by Anita Graser almost 4 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Closed
  • Assignee deleted (nobody -)
  • Target version changed from Future Release - Lower Priority to Version 2.12
  • Resolution set to fixed/implemented

This seems fixed. I cannot reproduce it anymore.

Also available in: Atom PDF