Bug report #3679

eVis not working with point layers

Added by Donkagen2 - over 9 years ago. Updated about 9 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13738

Description

eVis Event ID and Browser have both stopped working.
Usning trunk and load a project that works with 1.6.0, using eVis ID and clicking on a point that works with 1.6.0 - the screen flashes and redraws, but no eVis window opens.
The behaviour with the Evis Event Browser is the same - screen flash but no eVis dialog.

eVis_problem.zip (4.34 KB) Donkagen2 -, 2011-03-29 03:47 AM

History

#1 Updated by Bill Williamson over 9 years ago

  • Status changed from Open to Closed
  • Resolution set to worksforme

Works for me
Win7 rev 15622

#2 Updated by Donkagen2 - over 9 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (worksforme)

Replying to [comment:1 billywill]:

Works for me
Win7 rev 15622

Just tried it again with XP (SP3) rev 15622 and it still doesn't work.
Could this be something specific to XP and/or my installation?

#3 Updated by Giovanni Manghi over 9 years ago

Replying to [comment:2 Donkagen2]:

Replying to [comment:1 billywill]:

Works for me
Win7 rev 15622

Just tried it again with XP (SP3) rev 15622 and it still doesn't work.
Could this be something specific to XP and/or my installation?

try post sample data so we can test locally

#4 Updated by Donkagen2 - over 9 years ago

Replying to [comment:3 lutra]:

Replying to [comment:2 Donkagen2]:

Replying to [comment:1 billywill]:

Works for me
Win7 rev 15622

Just tried it again with XP (SP3) rev 15622 and it still doesn't work.
Could this be something specific to XP and/or my installation?

try post sample data so we can test locally

File "eVis problem.zip" attached. Contains minimal project with a single point shapefile with attributes identifying files to open via eVis.

#5 Updated by Donkagen2 - over 9 years ago

Tried again with rev 15676 and the previously uploaded project file.
Select point layer, select eVis event ID tool, click on a feature... screen flash, but nothing else. Then close QGIS - crash.

#6 Updated by geofff - about 9 years ago

Hi,
Same problem for me (windows 7, qgis 1.7.0 15695 )
Evis works well with qgis 1.6 but not with 1.7.0 (from osgeo4w).
I select a layer (point or line), open evis event ID tool or event brower : nothing happen, no flash, no movement. But when i choose "data base connection", it works, a window appears.

#7 Updated by geofff - about 9 years ago

Replying to [comment:6 geofff]:

Hi,
Same problem for me (windows 7, qgis 1.7.0 15695 )
Evis works well with qgis 1.6 but not with 1.7.0 (from osgeo4w).
I select a layer (point or line), open evis event ID tool or event brower : nothing happen, no flash, no movement. But when i choose "data base connection", it works, a window appears.

Edit : after trying to open evis event ID tool or event brower without results, i close qgis and it crashs, just like Donkagen2

#8 Updated by Alexander Bruy about 9 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Should be fixed in fbd10b55 (SVN r15741)

Also available in: Atom PDF