Bug report #3676

Add option to specify field width when exporting ShapeFile

Added by lfedje - over 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13735

Description

I made the following post in the forum.

"I am new to QGIS so please bear with my ignorance.

I am using QGIS Version 1.6.0 on an iMac i7.

I created a Google Earth plotting of over 1000 properties with fairly long titles and substantial descriptions. One of my clients wants me to provide them with a ShapeFile of their properties together with the text so that they can load it onto their existing GIS system.

This is what I have done so far:

I added a vector layer from a kml file I produced from Google Earth. The shapefile opens up just beautiful in QGIS and if I click on any one of the properties (using the info icon) all of the pertinent information that I put into Google Earth shows up just fine in "identify results". The problem that I am having is that when saving the shapefile ( Layer > Save As > ESRI Shapefile). The result when viewed on my clients system is that the shapes show up perfectly but the text information is truncated. I took a look at the data in the dbf file and find that all of the descriptions and names are shown as character,80.

Is there any way to increase the field size for name and description of the data being exported or is it just the nature of the program?

Any help with this would be greatly appreciated

Thanks in advance"

I followed this up with a ticket to GDAL wherein they have since responded. I placed their response in the following thread. Someone then mentioned that I report this as a possible bug.

http://forum.qgis.org/viewtopic.php?f=2&t=8259

Thanks

Loren

History

#1 Updated by Paolo Cavallini over 8 years ago

  • Subject changed from Exporting ShapeFile to Add option to specify field width when exporting ShapeFile
  • Assignee deleted (nobody -)
  • Pull Request or Patch supplied set to No

#2 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Paolo Cavallini about 8 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Médéric RIBREUX over 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Hello, bug triage...

in QGIS 2.13 you can export to a shapefile without characters limitation other than Shapefile format limit (254 characters max for a text attribute). I've made test with some exports and there is no truncation after 80 characters.

I am closing this bug.

Also available in: Atom PDF