Feature request #366

Adding a new column to a (dbf) table?

Added by neteler-itc-it - almost 14 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:Vectors
Pull Request or Patch supplied: Resolution:duplicate
Easy fix?:No Copied to github as #:10425

Description

Hi,

it would be nice to have the possibility to add a new column to a (dbf) attribute table.

Thanks,

Markus

History

#1 Updated by Tim Sutton over 12 years ago

Changed priority since major: does not work as expected should be used for features that are implemented but broken. We still need to implement this feature, though I agree its an important one to have.

#2 Updated by Jürgen Fischer about 12 years ago

this should probably added to the OGR shape driver. QGIS would automatically pick it up, once the OGR would support it.

#4 Updated by Paolo Cavallini about 12 years ago

Anyway, this is now possible (and easy) with a python plugin. Maybe the ticked can be closed?

#5 Updated by Markus Neteler about 12 years ago

Which plugin is that? Does it add a new button to the table manager?

#6 Updated by Paolo Cavallini about 12 years ago

Carson Farmer's fTools>Table tools

#7 Updated by Paolo Cavallini about 12 years ago

Sorry, I was wrong. It's Table Manager from Borys Jurgiel repo

#8 Updated by Jürgen Fischer almost 12 years ago

FYI there's patch to OGR to do this: http://trac.osgeo.org/gdal/ticket/2672

#9 Updated by Redmine Admin over 11 years ago

In gdal/ogr 1.6 is possible to add new attributes and the functionality is already implemented in qgis through the properties dialog. Should this ticket be closed?

#10 Updated by Jürgen Fischer over 11 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

duplicate of b87e3053 (SVN r1447)

#11 Updated by Jürgen Fischer over 11 years ago

Replying to [comment:13 jef]:

duplicate of b87e3053 (SVN r1447)

ouch, #1446 that is.

Also available in: Atom PDF