Bug report #3635

v.db.what.connect does not work

Added by Paolo Cavallini over 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GRASS
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13694

Description

v.db.connect [email protected] =line =1 -p

Vector map  is connected by:
layer  table  in database  through driver  with key 
Successfully finished

History

#1 Updated by Paolo Cavallini over 9 years ago

The same command works from the shell:

v.db.connect [email protected] =line =1 -p

GRASS_INFO_MESSAGE(13126,1): Vector map <[email protected]> is connected by:
GRASS_INFO_END(13126,1)
layer <1> table <strade> in database </home/Documenti/datigrass/Toscana/paolo/dbf/> through driver <dbf> with key <cat>

I suspect GRASS_INFO_END interferes here.

#2 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Pull Request or Patch supplied set to No
  • Affected QGIS version set to master

Also, v.db.connect -p does not display parameters between "< >"

v.db.connect [email protected] -p

Vector map is connected by:
layer table in database through driver with key

From the shell:

v.db.connect [email protected] -p

GRASS_INFO_MESSAGE(20127,1): Vector map <[email protected]> is connected by:
GRASS_INFO_END(20127,1)
layer <1> table <province> in database </home/paolo/grass/Toscana/paolo/dbf/> through driver <dbf> with key <cat>

#4 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#5 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Paolo Cavallini about 6 years ago

  • Assignee deleted (Paolo Cavallini)

#7 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#8 Updated by Médéric RIBREUX over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Hello, bug triage...

this is fixed in QGIS 2.13 master. This is the result of v.db.what.connect on a GRASS layer:

v.db.connect [email protected]_VELO -p
layer <1> table <VOIE_TRONCON_L> in database <C:\\Temp\\GRASS\\NANTES_METROPOLE\\OSM_VELO\\dbf\\> through driver <dbf> with key <cat>

Vector map <[email protected]_VELO> is connected by:

Successfully finished

I am closing this bug.

Also available in: Atom PDF