Bug report #3627

Raster calculator: -1 invalid expression

Added by Paolo Cavallini over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13686

Description

Currently these expressions are invalid:

([email protected])*-1
([email protected])*(-1)

because there is no unary minus in the raster calc grammar yet
(%left UMINUS // fictitious symbol (for unary minus) ).

As a workaround, ([email protected])* (0-1) is ok

History

#1 Updated by Marco Hugentobler over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Added in 2edcfa66 (SVN r15527)

Also available in: Atom PDF