Bug report #3571

Icons disappearing when opening attribute table

Added by Ivan Mincik over 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13631

Description

Icons are disappearing when opening attribute table in dock window.

How to replicate:
Configure Your QGIS to "Open attribute table in dock
window", load this example data r1 and choose Layer -> Open Attribute Table.

Attribute table window is opened with blank buttons without
any icons. Icons will appear when moving mouse cursor over. The same I
can reproduce when resizing attribute table window. When using attribute table in separate window
(not in dock window), icons are loaded correctly.

Software details:
OS: Debian Squeeze - Gnome, standard Clearlooks theme using Clearlooks buttons
QGIS: Trunk (I remember this behavior for versions in last few weeks)

Confirmed in Qgis-dev mailinglist r2

r1 - http://gista.sk/home/ivo/dl/qgis_demodata.tar.gz
r2 - http://lists.osgeo.org/pipermail/qgis-developer/2011-March/013235.html

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini about 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#3 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#5 Updated by Médéric RIBREUX over 4 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Closed
  • Assignee deleted (nobody -)
  • Resolution set to fixed/implemented

Hello, bug triage...

I cannot reproduce it in QGIS 2.13 master. I think it has been fixed.

I am closing this bug.

Also available in: Atom PDF