Bug report #3544

Save Selection as Shapefile changes database field info

Added by pastephe - over 9 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13604

Description

Using QGIS 1.4 on Debian GNU/Linux, "Save Selection as Shapefile" resulted in Date fields being re-written as Text fields in the resulting Shapefile.

History

#1 Updated by Giovanni Manghi over 9 years ago

What is your original datatsource? the shapefile do not have a "date" datatype.

#2 Updated by pastephe - over 9 years ago

The source is a municipal database, I believe. This document indicates dBase has supported the Date format at least since its writing in 2001: http://www.dbase.com/knowledgebase/int/dateobject/dateobject.htm

In addition, performing the same routine with ArcMap leaves the Date field intact.

#3 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#4 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#5 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#7 Updated by Médéric RIBREUX almost 5 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Closed
  • Assignee deleted (nobody -)
  • % Done changed from 0 to 100
  • Resolution set to fixed/implemented

Hello, bug triage...

in QGIS 2.13 master, exporting a layer with Date attribute in Shapefile preserves the Date attribute (tests done from a memory layer to a shapefile). QGis converts it to a QDate if date formatting is correct.

I am closing this bug.

Also available in: Atom PDF