Bug report #3539

v.to.db: allow selecting 2/3 columns

Added by Enrico Fiore almost 10 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GRASS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:13599

Description

When I try to upload x, y and z coordinates from vector geometry to attribute table, I can't select from menù the tree column to update, but only one, this creates an error because the comand requires two or tree column to run.

Associated revisions

Revision 250fcbcd
Added by Radim Blazek almost 5 years ago

[GRASS] multiple vector field option, fixes #3539

History

#1 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

#3 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Giovanni Manghi about 8 years ago

  • Operating System deleted (Windows)
  • Pull Request or Patch supplied set to No
  • Status info deleted (0)
  • Subject changed from GRASS Plugin - v.to.db to v.to.db: allow selecting 2/3 columns

#5 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Médéric RIBREUX about 5 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

this is still valid for QGIS 2.13 master.
The interface of this GRASS Module in QGIS should be modified to allow more than one attribute field when using option 'coor': "Point coordinates X,Y or X,Y,Z".

#7 Updated by Médéric RIBREUX almost 5 years ago

  • Status changed from Feedback to Open

#8 Updated by Radim Blazek almost 5 years ago

  • Status changed from Open to Closed

#9 Updated by Radim Blazek almost 5 years ago

Fixed, additional fields may be added by '+' button. Still not perfect because fields must be added manually. Ideally number of fields would be automatically changed according to option selected, but it also depends on vector's dimension.

Also available in: Atom PDF