Bug report #3518

Spatial Query not selecting points in complex polygons

Added by fyford - almost 9 years ago. Updated about 4 years ago.

Status:Closed
Priority:Low
Assignee:Luiz Motta
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:13578

Description

Hi, I've noticed that when I select points within a polygon with a popular GIS (debateable) I have a higher hitrate than when doing the same in QGIS. After investigating the differences I found that with complex polygons - see attached images (The layer used was the UK's Ordinance and Survey's Master Map) points were ignored by QGIS and not by the other. I thought I'd take the time to let you know.

Cheers

Francois

ComplexPolygonESRI.png - Here we see another GIS where it uses the same layer and selects points fine (4.09 KB) fyford -, 2011-02-23 06:04 AM

ComplexPolySelectWithin.png - Here we see Qgis perform a select within and misses some points (21.9 KB) fyford -, 2011-02-23 06:06 AM

SelectWorkingDonut.png - Here we see QGis perform a select within that works (9.94 KB) fyford -, 2011-02-23 06:06 AM

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Assignee set to Luiz Motta
  • Target version deleted (Version 1.7.0)
  • Pull Request or Patch supplied set to No

#2 Updated by Giovanni Manghi about 8 years ago

  • Target version set to Version 1.7.4

#3 Updated by Paolo Cavallini almost 8 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Jürgen Fischer over 5 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Médéric RIBREUX about 4 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

I can't reproduce it on QGIS 2.13 with a complex polygon (with holes).
I think we can close it but let me know if you can test it against your data.

#7 Updated by Giovanni Manghi about 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

closing for lack of feedback.

Also available in: Atom PDF