Bug report #3513

rasters causing qgis to crash

Added by Giovanni Manghi over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Redmine Admin
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13573

Description

Using r15215 under Ubuntu.

I think I found some kind of raster that causes QGIS to crash when the project CRS is not equal to the raster crs.

[Note1: Yes, I know that QGIS can't reproject rasters, but I guess that this kind of crashes should be avoided.]

[Note2: I don't see the same happen with the rasters in the qgis sample data set]

Example:

*) pick the attached raster, it is a geotiff defined in epsg:3763

*) set the project CRS as wgs84, epsg:4326

*) the raster obviously disappear from the canvas.

*) try zooming to the layer and/or changing the zoom level with the mouse wheel: QGIS starts eating memory and after a few seconds it crashes. Seg Fault.

*) I found other similar rasters that cause instant crash when the project crs is set to wgs84 and the user try to zoom to the layer

If it warp the same sample raster in wgs84 and I try the other way (project in epsg:3763) qgis does not crash.

I tested also r15223 with same results.

testpct.tif (90.1 KB) Giovanni Manghi, 2011-02-20 11:31 AM

testpctwgs84.tif (82.2 KB) Giovanni Manghi, 2011-02-20 11:32 AM

History

#1 Updated by Paolo Cavallini over 9 years ago

Confirmed. Syslog says:

Feb 21 17:39:40 ursus kernel: [35706.012419] qgis.binr31635: segfault at 7f86100cb000 ip 00007f865393e761 sp 00007ffff0f25ea8 error 6 in libc-2.11.2.so[7f86538bf000+158000]

#2 Updated by Anne Ghisla over 9 years ago

I can't reproduce the bug, with Fedora 14 up-to-date and QGIS .

Any hint of different package versions between Fedora and Ubuntu?

#3 Updated by Giovanni Manghi over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Well... now with raster OTFR this problem is certainly fixed. At least in my Ubuntu box. Reopen if necessary.

Also available in: Atom PDF