Bug report #3487

Select features by rectangle does not work properly

Added by elewis52 - about 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:13547

Description

Using the rectangle select tool, does not work properly. The tool selects some features inside the selected rectangle as well as selecting features outside the selection rectangle. This problem appears when a MySQL point data table is entered as a vector layer.
This is similar to other bugs reported and fixed some time ago for shape files.
This problem impacts MySQL; it does not appear to impact shape files. Selection from shape files appears to work properly

History

#1 Updated by luca76 - about 9 years ago

confirming.

Same problem here with select attributes by a circle, on a PostGis layer.

#2 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Paolo Cavallini almost 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#4 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Otto Dassau over 5 years ago

  • Pull Request or Patch supplied set to No

Hi,

I have a similar problem here for a shape point layer under windows 64bit QGIS 2.2 and 2.4. Only some points within a rectangle are shown as selected.

Can this be a hardware problem? Because it happens only on one PC and another one works fine.

Regards
Otto

#7 Updated by Médéric RIBREUX over 4 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

I can't reproduce it on PostGIS Point layer using all the selection tools. Do you still have it ? If it is the case could you attach a data set where the bug occurs ?

#8 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

closing for lack of feedback.

Also available in: Atom PDF