Bug report #3455

OTF or save as in another projection not work no more

Added by gede2a - over 8 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Projection Support
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:13515

Description

With a vector layer in WGS84 (mifmid or shape)cannot "move" it to Lambert4carto so all my projects do not work no more. It stays at the same place.
I can't even "save as" shape (or mifmid)from wgs84 to lambert 4 carto. Got this msg:
Export to vector file failed.
Error: Failed to transform a point while drawing a feature of type 'ifnGuagno'. Writing stopped. (Exception: forward transform of
(0.154603, 0.7364)

failed with error: failed to load datum shift file
)
Even with a project that was working with 1.5 and all previous versions since 0.7.4

History

#1 Updated by gede2a - over 8 years ago

In fact OTF only support EPSG projections not IGNF.
"Save as" works only if you don't change the CRS

#2 Updated by Jean-Roc Morreale over 8 years ago

+1 It occurs even with an updated IGNF register (#3394)

#3 Updated by Paolo Cavallini over 8 years ago

It may be related to #3537

#4 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#5 Updated by Paolo Cavallini over 7 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0

#6 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#7 Updated by Goyo D almost 7 years ago

  • Assignee deleted (nobody -)
  • Pull Request or Patch supplied set to No

Can't replicate using the latest master build for ubuntu 12.10.

#8 Updated by Giovanni Manghi almost 7 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Also available in: Atom PDF