Bug report #3449

GdalTools: unclear results from clipping

Added by Paolo Cavallini almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Giuseppe Sucameli
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13509

Description

Currently, when >1 layer is loaded into the canvas, clipping results are difficult to interpret. The tool attempts to clip all the loaded layers, whereas I guess the user expects only the topmost layer will be clipped.

History

#1 Updated by Giuseppe Sucameli almost 10 years ago

  • Status changed from Open to In Progress

All the active layers (visible ones) are clipped.
When more then one layer are active the result is the merge of all the active layers clipped by the extent.

In this moment there's an issue because the topmost layer is inserted as the first one in the gdal_merge command, but seeing at the gdal_merge manpages, "In areas of overlap, the last image will be copied over earlier ones".

So when there are > 1 layers active, in the result the last layer in the TOC is over the topmost one. I'm going to fix it as soon as possible.

#2 Updated by Giuseppe Sucameli almost 10 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

Replying to [comment:1 brushtyler]:

So when there are > 1 layers active, in the result the last layer in the TOC is over the topmost one. I'm going to fix it as soon as possible.

Fixed in 6129ea50 (SVN r15126).
I guess I can close this ticket.

Also available in: Atom PDF