Bug report #3443

line snapping fails to snap to it self

Added by marisn - over 9 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:end of life
Crashes QGIS or corrupts data:No Copied to github as #:13503

Description

Line snapping works just fine for existing lines but it fails to snap to new digitized line (it self). It's usefull to snap at minimum to line start point to provide creation of closed lines (rings).

Similar issue was recently fixed in GRASS GIS. http://trac.osgeo.org/grass/ticket/1255

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

#3 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by marisn - over 7 years ago

  • Pull Request or Patch supplied set to No

Ooooh how I hate to go report a bug and find out that somebody has already reported it long time a go. And that somebody is me :(

#5 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Giovanni Manghi over 4 years ago

  • Assignee deleted (Marco Hugentobler)
  • Status info deleted (0)
  • Operating System deleted (Gentoo)
  • Target version deleted (Future Release - Lower Priority)
  • Priority changed from Low to Normal

still true.

#7 Updated by Giovanni Manghi about 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#8 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to end of life
  • Status changed from Open to Closed

Also available in: Atom PDF