Bug report #3432

License conflict with GPLv3+ libs

Added by Volker Fröhlich over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:13492

Description

QGIS currently links two libraries, that are incompatible with QGIS' GPLv2+:

  • Libspatialite (GPLv3+)
  • Sqlanywhere (GPLv3+)

Linking a GPLv2+ program to GPLv3 libraries requires a switch to GPLv3+, as far as I can see.

http://fedoraproject.org/wiki/Licensing#GPL_Compatibility_Matrix

History

#1 Updated by Marco Hugentobler over 9 years ago

Hm, my interpretation from http://www.gnu.org/licenses/gpl-faq.html#v2v3Compatibility is that it should be possible:

'Is GPLv3 compatible with GPLv2? No ... However, if code is released under GPL “version 2 or later,” that is compatible with GPLv3 because GPLv3 is one of the options it permits '

#2 Updated by William Kyngesburye over 9 years ago

Huh? _lib_spatialite has always been on the Mozilla license, still is as of 2.4rc4. The spatialite tools and rasterlite use GPLv3, but those are not used in QGIS.

#3 Updated by Volker Fröhlich over 9 years ago

Kyngchaos, you're right about Libspatialite. I mixed that up with the tools and the other stuff.

But I still think, there is a conflict with Sqlanywhere's license.

#4 Updated by Paolo Cavallini over 9 years ago

Can anyone confirm this? Is so, I think we should drop SQLAnywhere support before releasing 1.7

#5 Updated by Volker Fröhlich over 9 years ago

libpal's version in Trunk is also GPLv3+, according to the headers.

The website states LPGL3, maybe they changed it for newer versions. If pal was only linked, it would be OK with GPLv2+.

But as far as I know, it was changed and changes did not go upstream. I'll try to help with that, as time allows.

#6 Updated by Volker Fröhlich over 9 years ago

Yes, pal 0.1 was GPLv3+, pal 0.2 is LGPLv3+.

#7 Updated by Tim Sutton over 9 years ago

Replying to [comment:4 pcav]:

Can anyone confirm this? Is so, I think we should drop SQLAnywhere support before releasing 1.7

Please note this was discussed in a private thread with the plugin developer before he contributed the code. I encouraged Dave to hold the discussions publicly which he did as soon as their lawyers gave the go ahead.

As Marco mentions above, our understanding is that it is ok for GPL v2 code to link to and include code with a later version of the GPL license.

Sybase have really gone out of their way to contribute their code the 'right' way and removing their plugin would not be a very generous or sympathetic move on our part.

It is our hope that Sybase's intiative may spur other proprietary geospatial database developers to copy suite and contribute open source client software for their systems. This would go a long way towards getting QGIS into the enterprise.

We are not licensing gurus, but lets find a way to make this work if there is a bona fide issue.

Regards

Tim

#8 Updated by Marco Hugentobler over 9 years ago

I still think it is no problem, because the QGIS code is under GPL2+. The important thing is the distribution of the program. It says in the header files:
"you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version". So if you are building packages (e.g. for Fedora), you redistribute them under GPL3 (any later version) and it should be ok.

Regards,
Marco

#9 Updated by Marco Hugentobler over 9 years ago

  • Status changed from Open to Closed
  • Resolution set to wontfix

Closing this bug after IRC discussion with volter. Result is that currently the only way to distribute QGIS is under GPL3 (most files are under GPLV2+, but PAL and sqlanywhere are GPLV3+).

#10 Updated by William Kyngesburye over 9 years ago

I suppose that means distributing binary packages also must be GPLv3?

#11 Updated by Marco Hugentobler over 9 years ago

Yes, exactly

#12 Updated by Volker Fröhlich over 9 years ago

"only way to distribute QGIS is under GPL3"

Shouldn't that be GPLv3+?

Also available in: Atom PDF