Bug report #3424

Mismatch between numbers of point in canvas and attribute table while using WFS

Added by dr - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Vectors
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13484

Description

Add WFS layer "ethno" from [http://gis-lab.info/scripts/tinyows/tinyows.cgi?] Number of points in canvas - 6, in attribute table 4 only.

Associated revisions

Revision 0c508871
Added by Jürgen Fischer almost 10 years ago

fix #3424

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 97149eda
Added by Jürgen Fischer almost 10 years ago

fix #3424

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Alexander Bruy almost 10 years ago

Confirmed under Linux and Windows, 44187c09 (SVN r15054)

#2 Updated by Maxim Dubinin almost 10 years ago

some points are identifiable even though they are not in the table

http://gis-lab.info/images/screenshots/20110118-h38-63kb.jpg

#3 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 97149eda (SVN r15057). Caused by a rounding problem when using the layer's extent to query the spatial index, which should probably be investigated. The provider now returns all loaded features.

Also available in: Atom PDF