Bug report #3347

Search query should warn when a column does not exist (instead of saying 0 matching features)

Added by Alister Hood almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13407

Description

Using the attribute table's "advanced search" button (or a rule-based rendering filter):
- Type a search query using an attribute column which doesn't exist (e.g. maybe you search for DIAM=150 because you misremembered the name of a column called DIA)
- Click the "test" button
- A message box will say "found 0 matching feature(s)"

It would be better to say "Column 'OBJECTI' does not exist".

bug3347fix.diff Magnifier - #3347_fix (785 Bytes) sunilkcube -, 2011-02-15 12:43 AM

patch_for_bug_3347.txt Magnifier (785 Bytes) sunilkcube -, 2011-02-15 01:02 AM

History

#1 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

patch applied in 1a4ff7dc (SVN r15176). Thanks Sunil.

Also available in: Atom PDF