Bug report #3341

GRASS MASK only vizualized for PERMANENT

Added by Otto Dassau over 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GRASS
Affected QGIS version:master Regression?:No
Operating System:SuSE Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:13401

Description

Hi,

QGIS only recognizes a GRASS MASK file correctly during vizualization, when the MASK file is in mapset PERMANENT. If MASK is in another mapset, the complete maps are drawn as usually.

Otto

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Pull Request or Patch supplied set to No
  • Assignee deleted (Lorenzo Masini)

#3 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Radim Blazek over 4 years ago

  • Status changed from Open to Closed

Rasters are masked in GRASS library until G_suppress_masking()/Rast_suppress_masking() is called. Rasters are masked by MASK raster from current mapset. While in traditional GRASS session there is always one mapset open as current, in QGIS, GRASS rasters may be rendered without opening a mapset. Because applying or not applying mask according to if a mapset is open or not would be very confusing, masking for rendering and querying rasters was disabled completely in QGIS in e7a0167.

Also available in: Atom PDF