Bug report #3334

Marker line renders wrong on rotate with line.

Added by Nathan Woodrow about 11 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Martin Dobias
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13394

Description

This is a bug when you select rotate with line but have a marker line defined with two symbols, one or more with offsets.

The problem seems to be that the angles of the symbols are updated correctly but the x and y offsets are not meaning that symbols render incorrectly along the line.

I have attached a picture of the problem. [[Image(http://imgur.com/bSymt.png)]]

Associated revisions

Revision e4236b3d
Added by Martin Dobias about 11 years ago

Rotate also marker's offset, not just the marker itself (fixes #3334)

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 1b69e082
Added by Martin Dobias about 11 years ago

Rotate also marker's offset, not just the marker itself (fixes #3334)

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Martin Dobias about 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in 1b69e082 (SVN r14915) - that was actually general problem of marker symbols when having both non-zero offset and rotation.

Also available in: Atom PDF