Bug report #3281

RasterCalc crashes QGIS

Added by Paolo Cavallini almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13341

Description

Doing a simple:

[email protected] - [email protected]

consistently throws an error:

Error:
         GDAL Error 2: CPLMalloc(): Out of memory allocating -1024 bytes.

bringing down QGIS.

Samples attached.

dtm_clip.tif (217 KB) Paolo Cavallini, 2010-12-01 09:25 AM

History

#1 Updated by Paolo Cavallini almost 10 years ago

Second raster too large to be attached. Available here:

http://int.faunalia.it/~paolo/dtm_interp4.tif

#2 Updated by Marco Hugentobler almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in . The problem was caused by the (south-up) orientation of raster dtm_interp4.tif

Also available in: Atom PDF