Bug report #327

QGIS can't save JPEG images on MS-Windows

Added by Redmine Admin about 14 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Pasetti -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10386

Description

It is unable to save map canvas as image (in Windows 0.8.0 Preview2 only, Linux version works)

History

#1 Updated by Gavin Macaulay - about 14 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Fixed in the preview3 0.8 version of qgis under windows

#2 Updated by Redmine Admin about 14 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

If you save as PNG image it works fine but if you choose JPEG format, only empty file is created :-(

#3 Updated by Gavin Macaulay - about 14 years ago

Works for me with the latest windows version of qgis (preview3). What version of qgis are you using?

#4 Updated by Redmine Admin about 14 years ago

Tim's latest WINDOWS build (created yesterday) from http://qgis.org/uploadfiles/testbuilds/qgis_setup.exe running on Windows XP SP2 Home edition.

#5 Updated by Gary Sherman almost 14 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

Works in current test build of Windows version (dated 2006-12-12).

#6 Updated by Redmine Admin over 12 years ago

The bug is back again :-(
Unable to save as JPEG in 0.9.1 and 0.9.2rc1.

#7 Updated by Redmine Admin over 12 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

The bug is back again :-( Unable to save as JPEG in 0.9.1 and 0.9.2rc1.

#8 Updated by 4everskiff - over 12 years ago

Replying to [comment:7 lubaby]:

The bug is back again :-( Unable to save as JPEG in 0.9.1 and 0.9.2rc1.

this is because I didn't built the jpeg support in MSYS/MinGW environment. I chose to not build it because it reported errors during some tests. The current environment has PNG and TIFF support, built with latest source code releases. GDAL uses internal supports for both PNG, TIFF and JPEG.

JPEG support is actually in my to-do list for next builds. Adding it since now would require some extra-time because I must re-build a lot of things depending on it (tiff, gdal, grass....).

If dev-team retains that is major bug to absolutely fix until 0.9.2 release I could setup the job, but, as I told above, it would require some extra time.

Marco

#9 Updated by Marco Pasetti - over 12 years ago

  • Status changed from Feedback to Open

I succesfully built the JPEG shared library on MinGW. It's works fine with GRASS.

It will be added to next QGIS build too.

Marco

#10 Updated by Paolo Cavallini over 12 years ago

It should have been fixed in the latest win installer. Let's wait for the final testing before closing it.

#11 Updated by Marco Pasetti - over 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in 0.11.0 Metis

#12 Updated by Anonymous over 11 years ago

Milestone Version 0.11.0 deleted

Also available in: Atom PDF