Feature request #3221

Fast, easy and beautiful on the fly rule-based rendering of OSM maps

Added by Mayeul Kauffmann almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Symbology
Pull Request or Patch supplied: Resolution:duplicate
Easy fix?:No Copied to github as #:13281

Description

Currently, rule-based rendering of openstreetmap.org-based maps is pretty slow, not easy to achieve (many data-management operation, need to apply patch manually and recompile...) and sometimes give ugly results. It should be fast, easy and beautiful.

Fast: to make navigation a fun experience; to allow doing this on old computers/computers without internet access (for users not having access to the slippy map).
Easy: because everybody can create new tags of tags, there are thousands of different tags. They will never be displayed all on online-rendered map. There are as many different needs as users. Each user should be able to define what he/she wants to render, and how, based on personal needs and tastes.
Beautiful: artefacts, unwanted graphic features and semantic needs that are impossible to meet make ugly maps; a beautiful map is easy to read for the ordinary user, rich and precise for the advanced user.

Below are links to related discussion and tickets related to achieving this more global need.
#3039
ticket:2832

History

#1 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #3222

Also available in: Atom PDF