Bug report #3203

GRASS toolbox: don't check for optional parameters

Added by Maciej Sieczka - almost 9 years ago. Updated over 3 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GRASS
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13263

Description

GRASS toolbox should not check if a parameter which is optional is set.

Case: r.cost supports various optional stopping points input. A vector map is one of them. However, if the a following line is added to it's qgm file:

<option key="stop_points" hidden="no" advanced="yes"/>

running the module throws an "Exception: Vector map <@PERMANENT> not found", although the command would run fine without stop_points specified.

History

#1 Updated by Maciej Sieczka - almost 9 years ago

Feature request #3204 is related.

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Pull Request or Patch supplied set to No
  • Assignee deleted (Lorenzo Masini)

#4 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#5 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Jürgen Fischer about 5 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#7 Updated by Radim Blazek over 3 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

It seems to be fixed. Tested with r.cost.vect.qgm and

<option key="stop_points" hidden="no" advanced="yes"/>

the option is added only if it is not empty.

Also available in: Atom PDF