Bug report #3202

Interchanges of colors in Random ramp

Added by dr - almost 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Martin Dobias
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13262

Description

1. Settings - Style manager - Color ramp;

2. Add couple of new Random ramps;

3. Set one of the ramp which was created on previous step and press minus button (delete);

4. Without selecting another ramps try press minus button again - colors in the second random ramps interchanges.

History

#1 Updated by Martin Dobias almost 10 years ago

Well, the random color ramp is indeed random - it doesn't store the generated values, so every time it is created it is filled with new random values from the specified range. That's why it may seem that the colors are interchanged.

#2 Updated by dr - almost 10 years ago

Ok, but why this happens with press Remove item button? I guess that this button need be blocked if no one ramps selected.

#3 Updated by Martin Dobias almost 10 years ago

Because the list is loaded again when you add/edit/remove anything. I agree that it should reload only when the style gets modified - done in .

#4 Updated by Alexander Bruy over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF