Bug report #3141

Georeferencer transformation type dropdown menu is incorrect

Added by dr - about 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13201

Description

If choose Polynomial 3 type and press OK, message "Polynomial 3 requires at least 1 GCPs. Please define more" appears.But polynomial 3 requires at least 10 GCPs. If choose another menu item, for example, polynomial 1 type, then message "Polynomial 1 requires at least 6 GCPs. Please define more" appears. But polynomial 1 requires 3 GCPs. And another menu items also incorrect.

georef-projective.patch Magnifier (1.19 KB) lynxID -, 2010-10-30 11:39 AM

History

#1 Updated by lynxID - almost 10 years ago

The reason of this bug is wrong place of the Projective transformation in the Transformation ComboBox. I have attached a patch that will fix this bug.

#2 Updated by Alexander Bruy almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Applied in 1828dd7e (SVN r14492)

Also available in: Atom PDF