Bug report #3119

actions not working if local OS is not "en" and "override system locale" (to en_US) is disabled

Added by Giovanni Manghi about 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Vectors
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13179

Description

take an OS not in english, and install QGIS localized as the OS.

Actions will not work, as the value of the %column variable is not translated to an actual value.

Enter the QGIS options and "override system locale" to en_US, actions will start to work.

Tested on qgis 1.5 on windows, but should be true also under linux.

History

#1 Updated by Jürgen Fischer about 10 years ago

no reproducable with trunk.

Although I noticed that %column is case-sensitive and the attribute of my test shape were uppercase. I must have played with actions on postgis before. Which datasource did you use?

#2 Updated by Giovanni Manghi about 10 years ago

It is reproducable at least with qgis installed on windows in portuguese. We used shapefiles, regardless the column name is upprcase or lowercase.

Tested both 1.5 and trunk.

#3 Updated by Alexander Bruy over 9 years ago

Can't reproduce with d7d7caf4 (SVN r15750) on Linux and Windows (both with Russian locale)

#4 Updated by Giovanni Manghi over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

it seems to work now, so closing. Tested on Window qith trunk/osgeo4w.

Also available in: Atom PDF