Bug report #3109

switching layers does not work

Added by Paolo Cavallini almost 9 years ago. Updated over 6 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:13169

Description

Deactivating a layer often does not result in the layer being switched off from the canvas

Associated revisions

Revision f0941ddc
Added by Jürgen Fischer almost 9 years ago

fix #3109

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 1684936b
Added by Jürgen Fischer almost 9 years ago

fix #3109

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer almost 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 1684936b (SVN r14378).

#2 Updated by Paolo Cavallini almost 9 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

It still happens in 12a404a6 (SVN r14379) (possibly less often than before)

#3 Updated by Andreas Neumann almost 9 years ago

same for me - the bug still exists on Windows OSGeo build 12a404a6 (SVN r14379).

On Ubuntu Lucid 64bit, the problem doesn't appear. Strange ...

#4 Updated by Paolo Cavallini over 8 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

It seems solved as per a75d755c (SVN r15310)

#5 Updated by Paolo Cavallini almost 8 years ago

  • Resolution deleted (worksforme)
  • Status changed from Closed to Open
  • Assignee deleted (nobody -)
  • Pull Request or Patch supplied set to No

It seems to have reappeared. If I switch cache off it is ok, when on the problem is still there.

#6 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.6.0 to Version 1.7.1

#7 Updated by Tim Sutton almost 8 years ago

  • Target version changed from Version 1.7.1 to Version 1.7.2

#8 Updated by Giovanni Manghi almost 8 years ago

Paolo Cavallini wrote:

It seems to have reappeared. If I switch cache off it is ok, when on the problem is still there.

still true for you? I cannot see it anymore.

#9 Updated by Paolo Cavallini almost 8 years ago

With caching OFF: load a layer, then a second one; switch off and on the top layer, ok; switch off and on the bottom layer, it remains on the canvas. It is more of an annoyance than a serious problem.

#10 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.2 to Version 1.7.3

#11 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.3 to Version 1.7.4

#12 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#13 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#14 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Paolo Cavallini wrote:

With caching OFF: load a layer, then a second one; switch off and on the top layer, ok; switch off and on the bottom layer, it remains on the canvas. It is more of an annoyance than a serious problem.

does not seems to happen anymore, please reopen if necessary.

Also available in: Atom PDF