Bug report #3055

(OsX) cannot type "@" in the GRASS shell

Added by Giovanni Manghi almost 9 years ago. Updated about 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GRASS
Affected QGIS version:master Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:13115

Description

Speaking obviously of the shell available in the QGIS GRASS plugin.

History

#1 Updated by William Kyngesburye almost 9 years ago

Works here, both OS X 10.5 and 10.6.

One thing I noticed is that after selecting the shell in the tool list, the window is not active (the cursor is a hollow rectangle) and typing anything does not work. After cllicking the window to activate it, I can type "@". What doesn't work that could be a problem for non-english users is accented characters. It show the accent as you type like it should (ie option-e for ´), but when you type the letter next the accent disappears and it's waiting for the next keystroke.

Another thing in the GRASS shell - no copy or paste of text.

#2 Updated by Giovanni Manghi almost 9 years ago

Hi,

One thing I noticed is that after selecting the shell in the tool list, the window is not active (the cursor is a hollow rectangle) and typing anything does not work.

we were already typing a command, so it is not the case.

After cllicking the window to activate it, I can type "@". What doesn't work that could be a >problem for non-english users is accented characters. It show the accent as you type like it >should (ie option-e for ´), but when you type the letter next the accent disappears and it's >waiting for the next keystroke.

for sure the keyboard wasn't english (pt-pt) and the hardware was a 13 inches Apple laptop (don't know how is called).

the problem has been confirmed on other Apple hardware (keyboards not US), but as I already said in other tickets, I'm just collecting OsX users feedback as I don't own any Apple hardware.

Another thing in the GRASS shell - no copy or paste of text.

I can copy/paste under Linux with shift-ctrl-c/shift-ctrl-v

#3 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#4 Updated by Paolo Cavallini over 7 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Pull Request or Patch supplied set to No
  • Assignee deleted (Lorenzo Masini)

#5 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#6 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#7 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Closed
  • Resolution set to worksforme

Cannot test OsX anynmore and I can only imagine that this is not a issue anymore.

Also available in: Atom PDF