Bug report #3048

Seg-fault on Debian Squeeze invoking any of GdalTools

Added by Giuseppe Sucameli about 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Giuseppe Sucameli
Category:GDAL Tools
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:13108

Description

The seg-fault occurs when no raster is loaded and one tries to invoke any of the tools except "About GdalTools?".

I am running Linux Debian Squeeze.
The builds are from the gfossit repository.

Here is a list of the libraries and executables.

ii  libqgis-dev                          1.5.0~svn20100411+gfossit60-2 Quantum GIS - development files
ii  libqgis1.5.0                         1.5.0~svn20100411+gfossit60-2 Quantum GIS - shared libraries
ii  python-qgis                          1.5.0~svn20100411+gfossit60-2 Python bindings to Quantum GIS
ii  python-qgis-common                   1.5.0~svn20100411+gfossit60-2 Python bindings to Quantum GIS - architectur
ii  qgis                                 1.5.0~svn20100411+gfossit60-2 Geographic Information System (GIS)
ii  qgis-common                          1.5.0~svn20100411+gfossit60-2 Quantum GIS - architecture-independent data
ii  qgis-plugin-grass                    1.5.0~svn20100411+gfossit60-2 GRASS plugin for Quantum GIS
ii  qgis-plugin-grass-common             1.5.0~svn20100411+gfossit60-2 GRASS plugin for Quantum GIS - architecture-

History

#1 Updated by Paolo Cavallini over 9 years ago

Can anyone replicate this? I cannot (in slightly different settings, though).

#2 Updated by Paolo Cavallini over 9 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

I am closing it pending confirmation.

Also available in: Atom PDF