Bug report #2976

Wrong properties display for GRASS Raster

Added by Jean-Roc Morreale about 9 years ago. Updated over 6 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:13036

Description

Properties of a GRASS raster are limited by defaut to Transparency/General/Metadata as the user can't modify things like color table without using grass' r.color.* tools but after loading non-grass raster, QGIS then display all the properties.

This behavior leads user to think that QGIS or their grass raster is broken, for example the grass raster display list with no item selected.

Steps to reproduce :
1. create a new project and open a grass dataset
2. load a grass raster, open its properties, then close it
3. load a non-grass raster, open its properties, then close it
4. reopen the grass' properties, it is now displaying the same ui than the non-grass raster

History

#1 Updated by Giovanni Manghi about 9 years ago

Replying to jrm:

Properties of a GRASS raster are limited by defaut to Transparency/General/Metadata as the user can't modify things like color table without using grass' r.color.* tools

this is because the GRASS rasters are no longer handled via GDAL. So you really need to have to use GRASS tools to configure/style them.

but after loading non-grass raster, QGIS then display all the properties.

This behavior leads user to think that QGIS or their grass raster is broken, for example the grass raster display list with no item selected.

Steps to reproduce :
1. create a new project and open a grass dataset
2. load a grass raster, open its properties, then close it
3. load a non-grass raster, open its properties, then close it
4. reopen the grass' properties, it is now displaying the same ui than the non-grass raster

confirmed. It is just enough to open the GRASS raster properties in QGIS, close the dialog and then reopen again.

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Giovanni Manghi over 6 years ago

  • Pull Request or Patch supplied set to No
  • Assignee deleted (nobody -)
  • Resolution set to fixed
  • Status changed from Open to Closed

does not happen anymore on master.

Also available in: Atom PDF