Bug report #293

a pattern fill is rendered wrong

Added by Redmine Admin about 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Martin Dobias
Category:Map Canvas
Affected QGIS version: Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:10352

Description

See the attached images. They present how the pattern fill for polygons is rendered bogus.

Maciek

patbug1.png (20.4 KB) Redmine Admin, 2006-09-22 01:44 PM

patbug2.png (17.8 KB) Redmine Admin, 2006-09-22 01:45 PM

patbug3.png (17.7 KB) Redmine Admin, 2006-09-22 01:45 PM

patbug4.png (18.7 KB) Redmine Admin, 2006-09-22 01:45 PM

History

#1 Updated by Redmine Admin about 14 years ago

I mean that those polygons which are filled with the blue pattern only partially, should be filled completely. Those yellowish in the background are not important here.

I hope it's clear.

To reproduce it take some narrow, long polygons (roads or rivers etc.) and try filling it with them a pattern.

Maciek

#2 Updated by Gavin Macaulay - about 14 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

This is a duplicate of ticket #83. A "sometimes works/sometimes doesn't" workaround is to turn on anti-aliasing - see #83 for more details.

#3 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF