Bug report #2866

Polygon looks like filled if set border style differ from Solid Line

Added by dr - over 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:12926

Description

Open any vector layer. Set border style (new symbology) to any value differ from Solid Line, for example Dot Line. Set Fill style to No brush. Start to zoom feature. After any steps of zooming polygon looks like filled.

06.07.png (82.7 KB) dr -, 2010-07-06 12:53 AM

History

#1 Updated by dr - over 9 years ago

Make lines appear less jagged at the expense of some drawing performance must be enabled.

#2 Updated by Martin Dobias over 9 years ago

I'm unable to reproduce to reproduce on Ubuntu 10.04 64-bit, Qt 4.6.2

#3 Updated by Giovanni Manghi over 9 years ago

Unable to reproduce with trunk (8586feb6 (SVN r14893)) under Linux. Still true under Windows?

#4 Updated by dr - over 9 years ago

Try to reproduce under Windows, looks like bug still exists (8586feb6 (SVN r14893)), winXP.

#5 Updated by Giovanni Manghi over 9 years ago

just tested osgeo4w/trunk under windows seven 32 bit and I cannot reproduce it.

#6 Updated by dr - over 9 years ago

Are you set "Make lines appear less jagged at the expense of some drawing performance must be enabled" option?

#7 Updated by Giovanni Manghi over 9 years ago

yes, on both OS

#8 Updated by Maxim Dubinin over 9 years ago

surprisingly I confirm, 8586feb6 (SVN r14893), WinXP, 32bit
"Make lines appear less" is turned off.

my style
http://gis-lab.info/images/screenshots/20101213-jig-40kb.jpg
example of an error
http://gis-lab.info/images/screenshots/20101213-wwe-78kb.jpg
layer (admin.shp)
http://gis-lab.info/data/geosample/admin.7z

#9 Updated by Giovanni Manghi over 9 years ago

The weirdest things is that today I can confirm it on win Seven, but only if "Make lines appear less jagged..." is turned on.

#10 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#11 Updated by Paolo Cavallini almost 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#12 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#13 Updated by Martin Dobias about 6 years ago

  • Assignee deleted (Martin Dobias)
  • Pull Request or Patch supplied set to No

#14 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#15 Updated by Médéric RIBREUX over 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Hello, bug triage...

I am not able to reproduce it under MS-Windows 7 for QGIS 2.13 master. I can zoom at any level and the polygon is never filled.

I am closing this bug.

Also available in: Atom PDF